blob: eeb4a79e53c1302c982a24673342843be922a8b4 [file] [log] [blame]
Chris Austen737b35f2015-10-25 00:21:04 -05001SUMMARY = "Phosphor OpenBMC Event Management"
2DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
Chris Austen3fef0762015-10-30 15:59:47 -05003HOMEPAGE = "https://github.com/openbmc/phosphor-event"
Chris Austen737b35f2015-10-25 00:21:04 -05004PR = "r1"
5
6
7inherit obmc-phosphor-license
8inherit obmc-phosphor-event-mgmt
9inherit obmc-phosphor-sdbus-service
10inherit obmc-phosphor-c-daemon
11
Chris Austene6be0e32016-02-08 23:00:29 -060012TARGET_CPPFLAGS += "-std=c++11 -fpic"
Chris Austen737b35f2015-10-25 00:21:04 -050013
Chris Austen3fef0762015-10-30 15:59:47 -050014SRC_URI += "git://github.com/openbmc/phosphor-event"
15
Patrick Williams75de7b82016-08-13 09:04:15 -050016SRCREV = "4dad23916e69d55d692eca7389d67eb023c5ca66"
Chris Austen737b35f2015-10-25 00:21:04 -050017
18RDEPENDS_${PN} += "libsystemd"
19DEPENDS += "systemd"
20
21
22S = "${WORKDIR}/git"
23INSTALL_NAME = "event_messaged"
24
25do_install() {
Chris Austene6be0e32016-02-08 23:00:29 -060026 install -d ${D}/var/lib/obmc/events/
Chris Austen737b35f2015-10-25 00:21:04 -050027 install -m 0755 -d ${D}${sbindir}
28 install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
29}