blob: cd54d30db2e937d44767595afdd0f6029da47ef7 [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060017DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylak172fe102016-10-19 14:58:25 -050018PROVIDES += "virtual/obmc-logging-mgmt"
19RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
20
21SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams7d95e702017-01-27 11:50:06 -060022SRCREV = "ac784ccd09e68fc8d74ed3b308230d61f9c9e12a"
Adriana Kobylak172fe102016-10-19 14:58:25 -050023
24S = "${WORKDIR}/git"
25