Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Logging DBUS Object" |
| 2 | DESCRIPTION = "Logging DBUS Object" |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit obmc-phosphor-dbus-service |
| 10 | |
| 11 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "systemd" |
| 15 | DEPENDS += "python-mako-native" |
| 16 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 17 | DEPENDS += "sdbusplus sdbusplus-native" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 18 | PROVIDES += "virtual/obmc-logging-mgmt" |
| 19 | RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| 20 | |
| 21 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Patrick Williams | a9a2de6 | 2017-01-19 14:00:02 -0600 | [diff] [blame] | 22 | SRCREV = "09a05492066525ff44ef2bf9ac3bb9c7db2fea09" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |