Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Logging DBUS Object" |
| 2 | DESCRIPTION = "Logging DBUS Object" |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit obmc-phosphor-dbus-service |
| 10 | |
| 11 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "systemd" |
| 15 | DEPENDS += "python-mako-native" |
| 16 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 17 | DEPENDS += "sdbusplus sdbusplus-native" |
Adriana Kobylak | 7878409 | 2017-02-09 15:06:41 -0600 | [diff] [blame] | 18 | DEPENDS += "phosphor-dbus-interfaces" |
| 19 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 20 | PROVIDES += "virtual/obmc-logging-mgmt" |
| 21 | RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| 22 | |
| 23 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Patrick Williams | b3cf8d2 | 2017-02-16 17:00:04 -0600 | [diff] [blame] | 24 | SRCREV = "1f36a88109ab5a59b84032d9a2cfb8314f4fbea5" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |