Matt Spinler | b89b9e7 | 2017-04-17 16:34:24 -0500 | [diff] [blame] | 1 | SUMMARY = "Generate fan control YAML from the MRW" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit phosphor-fan |
| 7 | |
| 8 | DEPENDS += " \ |
| 9 | mrw-native \ |
| 10 | mrw-perl-tools-native \ |
| 11 | " |
| 12 | |
| 13 | PROVIDES += "virtual/phosphor-fan-control-fan-config" |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | |
| 17 | do_compile() { |
| 18 | ${bindir}/perl-native/perl \ |
| 19 | ${bindir}/gen_fan_zone_yaml.pl \ |
| 20 | -i ${datadir}/obmc-mrw/${MACHINE}.xml \ |
| 21 | -o ${S}/fans.yaml |
| 22 | } |
| 23 | |
| 24 | do_install() { |
| 25 | DEST=${D}${control_datadir} |
| 26 | install -D ${S}/fans.yaml ${DEST}/fans.yaml |
| 27 | } |