Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 1 | SUMMARY = "FRU properties config for ipmi-fru-parser" |
| 2 | PR = "r1" |
Patrick Venture | 59157a0 | 2018-11-03 16:35:10 -0700 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | a1cee09 | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 5 | |
| 6 | inherit native |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 7 | inherit phosphor-ipmi-fru |
| 8 | |
Ratan Gupta | dccf5ad | 2017-03-30 14:32:02 +0530 | [diff] [blame] | 9 | SRC_URI += "file://extra-properties.yaml" |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 10 | |
| 11 | PROVIDES += "virtual/phosphor-ipmi-fru-properties" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install() { |
| 16 | # This recipe is supposed to create an output yaml file with |
| 17 | # FRU property values extracted from the MRW. This example recipe |
| 18 | # provides a sample output file. |
| 19 | |
| 20 | DEST=${D}${properties_datadir} |
| 21 | install -d ${DEST} |
Ratan Gupta | dccf5ad | 2017-03-30 14:32:02 +0530 | [diff] [blame] | 22 | install extra-properties.yaml ${DEST} |
Deepak Kodihalli | 5b183e0 | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 23 | } |