Brad Bishop | 8660573 | 2015-11-18 10:56:38 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
Brad Bishop | 8660573 | 2015-11-18 10:56:38 -0500 | [diff] [blame] | 2 | |
Andrew Geissler | 20e22db | 2018-08-29 06:06:42 -0700 | [diff] [blame] | 3 | # Remove all python .py files from python recipe. Only the .pyc |
| 4 | # files are required. Only do this if the openbmc-phosphor-tiny |
| 5 | # distro feature is enabled |
| 6 | do_install_append_openbmc-phosphor-tiny() { |
Andrew Geissler | aa74640 | 2018-09-25 09:32:31 -0500 | [diff] [blame] | 7 | # The _sysconfigdata.py is a system configuration file generated |
| 8 | # during build time. It's used in the yocto packaging process so |
| 9 | # it is required to remain in the image. |
| 10 | find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata.py -exec rm {} \; |
Andrew Geissler | 20e22db | 2018-08-29 06:06:42 -0700 | [diff] [blame] | 11 | } |