Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash" |
| 2 | SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB" |
| 3 | DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol." |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-blobs" |
| 14 | DEPENDS += "phosphor-logging" |
| 15 | DEPENDS += "sdbusplus" |
Patrick Venture | f0bb2a9 | 2019-03-07 10:51:53 -0800 | [diff] [blame] | 16 | DEPENDS += "ipmi-blob-tool" |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash" |
Andrew Geissler | ac4a569 | 2019-03-11 21:42:02 +0000 | [diff] [blame] | 20 | SRCREV = "2bd7021d9adbcc63fda3d904b24e47820b735bad" |
Patrick Venture | 2ff2ecc | 2018-11-09 18:27:28 -0800 | [diff] [blame] | 21 | |
| 22 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 23 | FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}" |
| 24 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 25 | |
| 26 | BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so" |