Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 1 | SUMMARY = "To merge the Host and BMC config files generated from MRW " |
Nagaraju Goruganti | 5851dc1 | 2018-04-01 07:56:47 -0500 | [diff] [blame] | 2 | DESCRIPTION = "Merge host provided FRU info config file, fru info config, \ |
| 3 | which is not sent by host config, and BMC accessible FRU info config \ |
| 4 | files generated by gen-ipmi-fru.pl into a single config file. \ |
| 5 | fru-gen parser parses the merged config file and generates cpp file" |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 6 | PR = "r1" |
Patrick Venture | 7618b19 | 2018-11-03 16:34:52 -0700 | [diff] [blame] | 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 9 | |
| 10 | inherit native |
| 11 | inherit phosphor-ipmi-host |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory" |
| 14 | DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory" |
Nagaraju Goruganti | 5851dc1 | 2018-04-01 07:56:47 -0500 | [diff] [blame] | 15 | DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory" |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 16 | PROVIDES += "virtual/phosphor-ipmi-fru-merge-config" |
| 17 | |
| 18 | do_install_append() { |
| 19 | SRC=${config_datadir} |
| 20 | DEST=${D}${config_datadir} |
| 21 | install -d ${DEST} |
| 22 | cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml |
Nagaraju Goruganti | 5851dc1 | 2018-04-01 07:56:47 -0500 | [diff] [blame] | 23 | cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 24 | } |