blob: d94e245b3fa557c9485e307b4a1b158a0c91e0c5 [file] [log] [blame]
Vishwanatha Subbannab463f222017-04-28 15:35:10 +05301SUMMARY = "Phosphor GPIO monitor application"
2DESCRIPTION = "Application to monitor gpio assertions"
3HOMEPAGE = "http://github.com/openbmc/phosphor-gpio-monitor"
4PR = "r1"
Vishwanatha Subbannab463f222017-04-28 15:35:10 +05305LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7inherit autotools pkgconfig
8inherit obmc-phosphor-dbus-service
9
Gunnar Millsc238b652017-07-10 15:49:43 -050010GPIO_PACKAGES = " \
11 ${PN}-monitor \
12 ${PN}-presence \
13"
14
Brad Bishopb0f3efd2018-04-11 11:42:57 -040015PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}"
16ALLOW_EMPTY_${PN} = "1"
Gunnar Millsc238b652017-07-10 15:49:43 -050017SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
18
19RPROVIDES_${PN}-monitor += "virtual/obmc-gpio-monitor"
20RPROVIDES_${PN}-presence += "virtual/obmc-gpio-presence"
21
Vishwanatha Subbannab463f222017-04-28 15:35:10 +053022PROVIDES += "virtual/obmc-gpio-monitor"
Gunnar Millsc238b652017-07-10 15:49:43 -050023PROVIDES += "virtual/obmc-gpio-presence"
Vishwanatha Subbannab463f222017-04-28 15:35:10 +053024
25DEPENDS += "autoconf-archive-native"
26DEPENDS += "sdbusplus sdbusplus-native"
27DEPENDS += "phosphor-dbus-interfaces"
Patrick Williams94d3d062017-06-08 08:48:06 -050028DEPENDS += "libevdev"
Vishwanatha Subbannab463f222017-04-28 15:35:10 +053029DEPENDS += "phosphor-logging"
Vishwanatha Subbannab463f222017-04-28 15:35:10 +053030
Gunnar Millsc238b652017-07-10 15:49:43 -050031RDEPENDS_${PN}-monitor += " \
32 libsystemd \
33 libevdev \
34 phosphor-logging \
35"
36RDEPENDS_${PN}-presence += " \
37 libsystemd \
38 libevdev \
39 phosphor-logging \
40 sdbusplus \
41"
42
43SYSTEMD_SERVICE_${PN}-monitor += "phosphor-gpio-monitor@.service"
44SYSTEMD_SERVICE_${PN}-presence += "phosphor-gpio-presence@.service"
45
46FILES_${PN}-monitor += "${sbindir}/phosphor-gpio-monitor"
47FILES_${PN}-monitor += "${sbindir}/phosphor-gpio-util"
48FILES_${PN}-presence += "${sbindir}/phosphor-gpio-presence"
Vishwanatha Subbannab463f222017-04-28 15:35:10 +053049
50SRC_URI += "git://github.com/openbmc/phosphor-gpio-monitor"
Andrew Geisslera1511bf2018-10-18 19:50:23 +000051SRCREV = "3c4a23e7764c7785d18cb30340a6d185022a797a"
Vishwanatha Subbannab463f222017-04-28 15:35:10 +053052S = "${WORKDIR}/git"