blob: bd4d678962bbb5aa96317a38b0f05d8592989a8b [file] [log] [blame]
Chris Austen737b35f2015-10-25 00:21:04 -05001SUMMARY = "Phosphor OpenBMC Event Management"
2DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
Chris Austen3fef0762015-10-30 15:59:47 -05003HOMEPAGE = "https://github.com/openbmc/phosphor-event"
Chris Austen737b35f2015-10-25 00:21:04 -05004PR = "r1"
5
6
7inherit obmc-phosphor-license
8inherit obmc-phosphor-event-mgmt
Brad Bishop745f13b2016-08-30 15:06:19 -04009inherit obmc-phosphor-dbus-service
Chris Austen737b35f2015-10-25 00:21:04 -050010inherit obmc-phosphor-c-daemon
11
Patrick Williams8592c8c2016-08-30 12:30:23 -050012TARGET_CXXFLAGS += " -std=c++11 -fpic"
13TARGET_CFLAGS += " -fpic"
Chris Austen737b35f2015-10-25 00:21:04 -050014
Chris Austen3fef0762015-10-30 15:59:47 -050015SRC_URI += "git://github.com/openbmc/phosphor-event"
16
Patrick Williamse43eee72016-08-30 12:30:03 -050017SRCREV = "059b35e1eabdd87ad02b4343692789386c134082"
Chris Austen737b35f2015-10-25 00:21:04 -050018
19RDEPENDS_${PN} += "libsystemd"
20DEPENDS += "systemd"
21
Brad Bishop745f13b2016-08-30 15:06:19 -040022DBUS_SERVICE_${PN} = "org.openbmc.records.events.service"
23SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/eventd/eventd.conf"
Chris Austen737b35f2015-10-25 00:21:04 -050024
25S = "${WORKDIR}/git"
26INSTALL_NAME = "event_messaged"
27
28do_install() {
Chris Austene6be0e32016-02-08 23:00:29 -060029 install -d ${D}/var/lib/obmc/events/
Chris Austen737b35f2015-10-25 00:21:04 -050030 install -m 0755 -d ${D}${sbindir}
Brad Bishop745f13b2016-08-30 15:06:19 -040031 install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/phosphor-eventd
Chris Austen737b35f2015-10-25 00:21:04 -050032}