Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC hwmon poller" |
| 2 | DESCRIPTION = "OpenBMC hwmon poller." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-python |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
| 8 | VIRTUAL-RUNTIME_skeleton_workbook ?= "" |
| 9 | |
| 10 | RDEPENDS_${PN} += "\ |
| 11 | python-dbus \ |
| 12 | python-json \ |
| 13 | python-shell \ |
| 14 | python-pygobject \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 15 | pyphosphor-dbus \ |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 16 | ${VIRTUAL-RUNTIME_skeleton_workbook} \ |
| 17 | " |
| 18 | |
| 19 | SKELETON_DIR = "pyhwmon" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 20 | TMPL = "mapper-wait@.service" |
| 21 | TGT = "obmc-fans-ready.target" |
| 22 | INSTFMT = "mapper-wait@-org-openbmc-sensors-speed-fan{0}.service" |
| 23 | FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}" |
| 24 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_FAN_INSTANCES')}" |