blob: 8ffc41b1cf633eb11ec319c0e43746776a0a9e80 [file] [log] [blame]
Brad Bishopce086742015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Matthew Barthe9972912016-10-05 16:20:54 -05008inherit pythonnative
9inherit autotools pkgconfig
Brad Bishopce086742015-10-27 17:12:45 -040010inherit obmc-phosphor-dbus-service
11inherit obmc-phosphor-systemd
Brad Bishopce086742015-10-27 17:12:45 -040012
Brad Bishop48b19612016-08-07 23:18:32 -040013DEPENDS += "systemd"
Matthew Barthe9972912016-10-05 16:20:54 -050014DEPENDS += "autoconf-archive-native"
Rick Altherrc38aae02016-08-01 14:20:50 -070015
Brad Bishopa5983c92016-08-16 09:40:10 -040016DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper.service"
Brad Bishop231230b2016-08-08 20:04:29 -040017SYSTEMD_SERVICE_${PN} = "mapper-wait@.service"
Matthew Barthe9972912016-10-05 16:20:54 -050018RDEPENDS_libmapper += "libsystemd"
Brad Bishopce086742015-10-27 17:12:45 -040019RDEPENDS_${PN} += " \
20 python-xml \
21 python-dbus \
22 python-pygobject \
23 "
Chris Austen350def12015-12-02 22:32:06 -060024SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishopce086742015-10-27 17:12:45 -040025
Matthew Barthe9972912016-10-05 16:20:54 -050026SRCREV = "7122244c83092499dc8d7836da0a63a08c734856"
Brad Bishopce086742015-10-27 17:12:45 -040027
28S = "${WORKDIR}/git"
Brad Bishop9a701b42016-07-26 15:52:01 -040029
Matthew Barthe9972912016-10-05 16:20:54 -050030export BUILD_SYS
31export HOST_SYS
32export STAGING_INCDIR
33export STAGING_LIBDIR
Brad Bishop9a701b42016-07-26 15:52:01 -040034
35python populate_packages_prepend () {
36 mapperlibdir = d.getVar("libdir", True)
37 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
38}
39PACKAGES_DYNAMIC += "^libmapper.*"
40FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
Matthew Barthe9972912016-10-05 16:20:54 -050041FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"