blob: 75a1d842954fa2dac1bc5c579be5d8f0d9f404ff [file] [log] [blame]
Jeremy Kerr49208ee2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
9
10TARGET_CFLAGS += "-fpic -O2"
11
12SRC_URI += "git://github.com/openbmc/obmc-console"
13SRC_URI += "file://${PN}.conf"
Jeremy Kerr8c940192016-04-12 15:59:52 +080014SRCREV = "2eacda524e98c7964e542e01aabf82360cf60344"
Jeremy Kerr49208ee2016-03-17 17:35:27 +080015
16do_install_append() {
17 install -m 0755 -d ${D}${sysconfdir}
18 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
19}
20
21S = "${WORKDIR}/git"