blob: 9ef8793c19a823a9d5d3daee7603182f4bf6f3cb [file] [log] [blame]
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
Patrick Venturef0bb2a92019-03-07 10:51:53 -080016DEPENDS += "ipmi-blob-tool"
Patrick Venturecb35b592019-05-03 10:35:28 -070017DEPENDS += "pciutils"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080018
19S = "${WORKDIR}/git"
20SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geisslerd77a3b72019-05-07 17:02:03 +000021SRCREV = "36bb4670546dfab9e14bc01738aed7d0eac8f324"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080022
23FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
25FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
26
27BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"