Matt Spinler | d78cb46 | 2016-10-17 11:20:01 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor Device Tree Generator" |
| 2 | DESCRIPTION = "Script to generate the BMC device tree from the MRW XML" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/git" |
| 6 | |
| 7 | inherit obmc-phosphor-license |
| 8 | inherit native |
| 9 | inherit mrw-rev |
| 10 | |
| 11 | DEPENDS += "yaml-tiny mrw-api-native" |
| 12 | |
| 13 | SRC_URI += "${MRW_TOOLS_SRC_URI}" |
| 14 | SRCREV = "${MRW_TOOLS_SRCREV}" |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${STAGING_BINDIR_NATIVE} |
| 18 | install -m 0755 gen_devtree.pl ${D}${STAGING_BINDIR_NATIVE}/gen_devtree.pl |
| 19 | } |