Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor GPIO monitor application" |
| 2 | DESCRIPTION = "Application to monitor gpio assertions" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-gpio-monitor" |
| 4 | PR = "r1" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 8 | inherit autotools pkgconfig |
| 9 | inherit obmc-phosphor-dbus-service |
| 10 | |
Gunnar Mills | c238b65 | 2017-07-10 15:49:43 -0500 | [diff] [blame] | 11 | GPIO_PACKAGES = " \ |
| 12 | ${PN}-monitor \ |
| 13 | ${PN}-presence \ |
| 14 | " |
| 15 | |
Brad Bishop | b0f3efd | 2018-04-11 11:42:57 -0400 | [diff] [blame] | 16 | PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}" |
| 17 | ALLOW_EMPTY_${PN} = "1" |
Gunnar Mills | c238b65 | 2017-07-10 15:49:43 -0500 | [diff] [blame] | 18 | SYSTEMD_PACKAGES = "${GPIO_PACKAGES}" |
| 19 | |
| 20 | RPROVIDES_${PN}-monitor += "virtual/obmc-gpio-monitor" |
| 21 | RPROVIDES_${PN}-presence += "virtual/obmc-gpio-presence" |
| 22 | |
Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 23 | PROVIDES += "virtual/obmc-gpio-monitor" |
Gunnar Mills | c238b65 | 2017-07-10 15:49:43 -0500 | [diff] [blame] | 24 | PROVIDES += "virtual/obmc-gpio-presence" |
Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 25 | |
| 26 | DEPENDS += "autoconf-archive-native" |
| 27 | DEPENDS += "sdbusplus sdbusplus-native" |
| 28 | DEPENDS += "phosphor-dbus-interfaces" |
Patrick Williams | 94d3d06 | 2017-06-08 08:48:06 -0500 | [diff] [blame] | 29 | DEPENDS += "libevdev" |
Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 30 | DEPENDS += "phosphor-logging" |
Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 31 | |
Gunnar Mills | c238b65 | 2017-07-10 15:49:43 -0500 | [diff] [blame] | 32 | RDEPENDS_${PN}-monitor += " \ |
| 33 | libsystemd \ |
| 34 | libevdev \ |
| 35 | phosphor-logging \ |
| 36 | " |
| 37 | RDEPENDS_${PN}-presence += " \ |
| 38 | libsystemd \ |
| 39 | libevdev \ |
| 40 | phosphor-logging \ |
| 41 | sdbusplus \ |
| 42 | " |
| 43 | |
| 44 | SYSTEMD_SERVICE_${PN}-monitor += "phosphor-gpio-monitor@.service" |
| 45 | SYSTEMD_SERVICE_${PN}-presence += "phosphor-gpio-presence@.service" |
| 46 | |
| 47 | FILES_${PN}-monitor += "${sbindir}/phosphor-gpio-monitor" |
| 48 | FILES_${PN}-monitor += "${sbindir}/phosphor-gpio-util" |
| 49 | FILES_${PN}-presence += "${sbindir}/phosphor-gpio-presence" |
Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 50 | |
| 51 | SRC_URI += "git://github.com/openbmc/phosphor-gpio-monitor" |
Andrew Geissler | 9811d3f | 2018-10-04 19:40:19 +0000 | [diff] [blame] | 52 | SRCREV = "bd0904b1e92a61d98b49fa9a20765b51b2a62348" |
Vishwanatha Subbanna | b463f22 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 53 | S = "${WORKDIR}/git" |