Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC org.openbmc.Watchdog example implementation" |
| 2 | DESCRIPTION = "A sample implementation for the org.openbmc.Watchdog DBUS API." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-gdbus |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
| 8 | SKELETON_DIR = "hostwatchdog" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 9 | |
| 10 | FMT = "org.openbmc.watchdog.Host@{0}.service" |
| 11 | DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_WATCHDOG_INSTANCES')}" |
| 12 | SYSTEMD_SERVICE_${PN} += "obmc-start-watchdog@.service obmc-stop-watchdog@.service" |
| 13 | |
| 14 | START_TMPL = "obmc-start-watchdog@.service" |
| 15 | START_TGTFMT = "obmc-chassis-start@{1}.target" |
| 16 | START_INSTFMT = "obmc-start-watchdog@{0}.service" |
Andrew Geissler | a31fba5 | 2017-02-08 15:54:25 -0600 | [diff] [blame] | 17 | START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 18 | |
| 19 | STOP_TMPL = "obmc-stop-watchdog@.service" |
| 20 | STOP_TGTFMT = "obmc-chassis-stop@{1}.target" |
| 21 | STOP_INSTFMT = "obmc-stop-watchdog@{0}.service" |
Andrew Geissler | a31fba5 | 2017-02-08 15:54:25 -0600 | [diff] [blame] | 22 | STOP_FMT = "../${STOP_TMPL}:${STOP_TGTFMT}.requires/${STOP_INSTFMT}" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 23 | |
| 24 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}" |
| 25 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'STOP_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}" |