Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 1 | HOMEPAGE = "github.com/openbmc/phosphor-pid-control" |
| 2 | |
| 3 | LICENSE = "Apache-2.0" |
James Feist | bca8c43 | 2018-08-02 14:23:38 -0700 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 5 | |
| 6 | SUMMARY = "Phosphor PID Fan Control" |
| 7 | DESCRIPTION = "Fan Control" |
| 8 | PR = "r1" |
| 9 | |
| 10 | SRC_URI = "git://github.com/openbmc/phosphor-pid-control" |
Andrew Geissler | 5289894 | 2018-08-22 16:50:04 -0500 | [diff] [blame] | 11 | SRCREV = "64f072a74c895de24b2ec7a5c829224e6abdf516" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit autotools pkgconfig |
| 15 | inherit pythonnative |
| 16 | |
| 17 | inherit phosphor-pid-control |
| 18 | inherit obmc-phosphor-ipmiprovider-symlink |
| 19 | |
| 20 | # Each platform will need a service file that starts |
| 21 | # at an appropriate time per system. For instance, if |
| 22 | # your system relies on passive dbus for fans or other |
| 23 | # sensors then it may be prudent to wait for all of them. |
| 24 | |
| 25 | DEPENDS += "autoconf-archive-native" |
| 26 | DEPENDS += "python-pyyaml-native" |
| 27 | DEPENDS += "python-mako-native" |
| 28 | DEPENDS += "sdbusplus" |
| 29 | DEPENDS += "phosphor-logging" |
| 30 | DEPENDS += "libevdev" |
| 31 | DEPENDS += "libconfig" |
| 32 | |
| 33 | # We depend on someone providing their system's configuration. |
| 34 | DEPENDS += "virtual/phosphor-fans-sensor-inventory" |
| 35 | # We depend on this to be built first so we can build our providers. |
| 36 | DEPENDS += "phosphor-ipmi-host" |
| 37 | |
| 38 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 39 | |
| 40 | FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor" |
| 41 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 42 | # The following installs the OEM IPMI handler for the fan controls. |
| 43 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 44 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 45 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 46 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 47 | |
| 48 | EXTRA_OECONF = "SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor-list.yaml \ |
| 49 | PID_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/pid-list.yaml \ |
| 50 | ZONE_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/zone-info.yaml" |
| 51 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 52 | HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so" |