Rick Altherr | 9222093 | 2016-12-08 12:21:49 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Small image capable of booting a device. The kernel includes \ |
| 2 | the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \ |
| 3 | first 'init' program more efficiently." |
| 4 | |
William A. Kennington III | 848bfdb | 2019-09-23 12:26:55 -0700 | [diff] [blame] | 5 | PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs" |
Rick Altherr | 9222093 | 2016-12-08 12:21:49 -0800 | [diff] [blame] | 6 | |
| 7 | # Do not pollute the initrd image with rootfs features |
William A. Kennington III | a04a0a5 | 2019-09-23 12:27:48 -0700 | [diff] [blame] | 8 | IMAGE_FEATURES = "read-only-rootfs" |
Rick Altherr | 9222093 | 2016-12-08 12:21:49 -0800 | [diff] [blame] | 9 | |
| 10 | export IMAGE_BASENAME = "obmc-phosphor-initramfs" |
| 11 | IMAGE_LINGUAS = "" |
| 12 | |
| 13 | LICENSE = "MIT" |
| 14 | |
| 15 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" |
| 16 | inherit core-image |
| 17 | |
| 18 | IMAGE_ROOTFS_SIZE = "8192" |
| 19 | IMAGE_ROOTFS_EXTRA_SPACE = "0" |
| 20 | |
William A. Kennington III | 848bfdb | 2019-09-23 12:26:55 -0700 | [diff] [blame] | 21 | # Needed for the set_user_group functions to succeed |
| 22 | DEPENDS += "shadow-native" |
| 23 | |
Richard Marian Thomaiyar | 17d1d72 | 2018-10-03 10:47:25 +0530 | [diff] [blame] | 24 | PACKAGE_INSTALL_remove = "shadow" |
| 25 | PACKAGE_EXCLUDE = "shadow" |
Rick Altherr | 9222093 | 2016-12-08 12:21:49 -0800 | [diff] [blame] | 26 | BAD_RECOMMENDATIONS += "busybox-syslog" |