Xo Wang | 0d917d8 | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 1 | DESCRIPTION = "Command line tools for hardware device registers" |
| 2 | HOMEPAGE = "https://github.com/adurbin/iotools" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 5 | SRCREV = "452ad1f4957a4f307fbe204419e5d08a1a1febb9" |
| 6 | SRC_URI = "git://git@github.com/adurbin/iotools.git;protocol=https" |
| 7 | PV = "v1.6+git${SRCPV}" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | FILES_${PN} = "${sbindir}" |
| 11 | |
| 12 | do_compile() { |
| 13 | # CC is overridden in the Makefile, so override it harder in the invocation |
| 14 | oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0 |
| 15 | } |
| 16 | |
| 17 | # The "install" make target runs the binary to create links for subcommands. |
| 18 | # The links are excessive and this doesn't work for cross compiling. |
| 19 | do_install() { |
| 20 | install -d ${D}${sbindir} |
| 21 | install -m 0755 iotools ${D}${sbindir} |
| 22 | } |