blob: 9e757bcaae0e7a8d29838c712bcc7bfd4b021886 [file] [log] [blame]
Brad Bishop9ee75e12015-09-17 16:39:49 -04001# Common code for applications providing a D-Bus service.
2
3# Class users should define DBUS_SERVICES prior to including.
4
5python() {
6 services = d.getVar('DBUS_SERVICES', True).split()
7 uris = " ".join( [ 'file://' + s + '.conf' for s in services ] )
8 d.appendVar('SRC_URI', uris)
9}
10
11do_install_append() {
12 # install the service configuration files
13 install -d ${D}${sysconfdir}/dbus-1/system.d
14 for s in ${DBUS_SERVICES}; do
15 install ${WORKDIR}/$s.conf ${D}${sysconfdir}/dbus-1/system.d/$s.conf
16 done
17}