blob: b18ea01363da0f65d8fc5949eff2d3b81911ce29 [file] [log] [blame]
Tom Josephfddc4052017-01-16 16:43:05 +05301SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
Patrick Venture6ffd6b42018-10-01 20:54:34 -07005PV = "1.0+git${SRCPV}"
Patrick Venture367b85b2018-11-03 09:43:10 -07006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Tom Josephfddc4052017-01-16 16:43:05 +05308
9inherit autotools pkgconfig
Vernon Mauerye46895b2019-03-22 12:25:14 -070010inherit systemd
Tom Josephfddc4052017-01-16 16:43:05 +053011
12DEPENDS += "autoconf-archive-native"
Vernon Mauerya1e96ee2019-04-12 14:06:06 -070013DEPENDS += "cli11"
Tom Josephfddc4052017-01-16 16:43:05 +053014DEPENDS += "phosphor-mapper"
15DEPENDS += "systemd"
16DEPENDS += "phosphor-ipmi-host"
Tom Josephfddc4052017-01-16 16:43:05 +053017
Brad Bishop26921a32020-08-10 20:18:26 -040018RRECOMMENDS_${PN} = "pam-ipmi"
19
Tom Josephfddc4052017-01-16 16:43:05 +053020SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
Andrew Geisslerfc7a6912020-08-19 18:11:35 +000021SRCREV = "07bb095158b39cedb49dae0972e489a6a2776faf"
Tom Josephfddc4052017-01-16 16:43:05 +053022
23S = "${WORKDIR}/git"
24
Vernon Mauerye46895b2019-03-22 12:25:14 -070025FILES_${PN} += " \
26 ${systemd_system_unitdir}/${PN}@.service \
27 ${systemd_system_unitdir}/${PN}@.socket \
Tom Joseph12798692017-01-27 14:11:58 +053028 "
Vernon Mauerye46895b2019-03-22 12:25:14 -070029
30# If RMCPP_IFACE is not set by bbappend, set it to default
31DEFAULT_RMCPP_IFACE = "eth0"
32RMCPP_IFACE ?= "${DEFAULT_RMCPP_IFACE}"
33
34# install parameterized service and socket files
35SYSTEMD_SERVICE_${PN} = " \
36 ${PN}@${RMCPP_IFACE}.service \
37 ${PN}@${RMCPP_IFACE}.socket \
38 "
39
40# To add another RMCPP interface, add similar lines to the
41# following lines in a bbappend:
42#
43# ALT_RMCPP_IFACE = "eth1"
44# SYSTEMD_SERVICE_${PN} += " \
45# ${PN}@${ALT_RMCPP_IFACE}.service \
46# ${PN}@${ALT_RMCPP_IFACE}.socket \
47# "
48
49# Also, be sure to enable a corresponding entry in the channel
50# config file with the same 'name' as the interfaces above
51# Override the default phosphor-ipmi-config.bb with a bbappend
52