blob: 1f5df6d272e2d8c25356467ec9b3c78546bade75 [file] [log] [blame]
Ratan Guptab92d0ec2017-03-06 17:05:11 +05301SUMMARY = "Sensor config for phosphor-host-ipmi"
2PR = "r1"
Patrick Ventured633d432018-11-03 16:36:58 -07003LICENSE = "Apache-2.0"
Brad Bishopa1cee092019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ratan Guptab92d0ec2017-03-06 17:05:11 +05305
6inherit native
7inherit phosphor-ipmi-host
Ratan Guptab92d0ec2017-03-06 17:05:11 +05308
9PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe is supposed to create an output yaml file with
17 # sensor data extracted from the mrw.
18 # provides a sample output file.
19
Ratan Guptab76fa562017-03-17 19:37:28 +053020 DEST=${D}${sensor_datadir}
Ratan Guptab92d0ec2017-03-06 17:05:11 +053021 install -d ${DEST}
22 install config.yaml ${DEST}/sensor.yaml
23}