blob: e6ac942bd0265fbfabcab94465a889063558bc69 [file] [log] [blame]
Deepak Kodihalli394e8672019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit meson pkgconfig
Deepak Kodihalli127d8972020-06-22 05:25:35 -05007inherit systemd
Deepak Kodihalli394e8672019-10-14 01:23:27 -05008
9require pldm.inc
10
11DEPENDS += "systemd"
Matt Spinler6fd86c42020-01-20 14:09:47 -060012DEPENDS += "sdeventplus"
Deepak Kodihalli394e8672019-10-14 01:23:27 -050013DEPENDS += "phosphor-dbus-interfaces"
14DEPENDS += "nlohmann-json"
Deepak Kodihalli394e8672019-10-14 01:23:27 -050015DEPENDS += "cli11"
16
17S = "${WORKDIR}/git"
18
Deepak Kodihalli127d8972020-06-22 05:25:35 -050019SYSTEMD_SERVICE_${PN} += "pldmd.service"
Chicago Duan42365972020-08-27 15:07:55 +080020SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service"
Deepak Kodihalli127d8972020-06-22 05:25:35 -050021
Deepak Kodihalli394e8672019-10-14 01:23:27 -050022EXTRA_OEMESON = " \
23 -Dtests=disabled \
24 -Doem-ibm=disabled \
25 "
Andrew Geissler5e124cd2020-10-28 16:43:35 -050026
27# Install pldmSoftPowerOff.service in correct targets
28pkg_postinst_${PN} () {
29
30 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
31 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
32 TARGET="../pldmSoftPowerOff.service"
33 ln -s $TARGET $LINK
34
Andrew Geisslerdfa2d6b2020-12-09 16:03:36 -060035 mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
36 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service"
37 TARGET="../pldmSoftPowerOff.service"
38 ln -s $TARGET $LINK
39
Andrew Geissler5e124cd2020-10-28 16:43:35 -050040 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
41 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
42 TARGET="../pldmSoftPowerOff.service"
43 ln -s $TARGET $LINK
44}
45
46pkg_prerm_${PN} () {
47
48 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
49 rm $LINK
50
Andrew Geisslerdfa2d6b2020-12-09 16:03:36 -060051 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service"
52 rm $LINK
53
Andrew Geissler5e124cd2020-10-28 16:43:35 -050054 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
55 rm $LINK
56}