blob: ed32f379c6548a035b36b8ddc854217ac8d2552c [file] [log] [blame]
Benjamin Fairfc8a45a2020-04-10 13:01:48 -07001SUMMARY = "NVMe Drive Manager"
2DESCRIPTION = "Daemon to monitor and report the status of NVMe drives"
3HOMEPAGE = "https://github.com/openbmc/phosphor-nvme"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16
17SRC_URI = "git://github.com/openbmc/phosphor-nvme.git;protocol=git"
Andrew Geissler1c47ccc2020-10-08 05:31:53 +000018SRCREV = "9b771e221e3854bbbf45a56bbcab97c62b0a05ec"
Benjamin Fairfc8a45a2020-04-10 13:01:48 -070019S = "${WORKDIR}/git"
20
21SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.nvme.manager.service"