blob: bb1847e8ddbebfae3a9319c45b6978b49b97aee1 [file] [log] [blame]
Lei YU4d8175e2019-10-21 10:39:07 +08001SUMMARY = "Phosphor Power services and utilities"
2DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \
3voltage regulators, and analyzes power devices for faults"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit meson
8inherit pkgconfig
9inherit systemd
10inherit pythonnative
11
12require ${PN}.inc
13
14S = "${WORKDIR}/git"
15
16# TODO: in future when openpower-dbus-interfaces is removed from
17# phosphor-power, remove the dependency here.
18DEPENDS += " \
19 phosphor-logging \
20 openpower-dbus-interfaces \
21 sdbus++-native \
22 sdeventplus \
23 nlohmann-json \
Jim Wright7a0e57f2019-11-06 15:43:43 -060024 cli11 \
Lei YU4d8175e2019-10-21 10:39:07 +080025 "
26
27SEQ_MONITOR_SVC = "pseq-monitor.service"
28SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
29PSU_MONITOR_TMPL = "power-supply-monitor@.service"
30SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}"