Gunnar Mills | 35591d4 | 2017-01-27 13:13:24 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor Software Management" |
| 2 | DESCRIPTION = "Phosphor Software Manager provides a set of system software \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | SOFTWARE_MGR_PACKAGES = " \ |
| 11 | ${PN}-version \ |
| 12 | " |
| 13 | PACKAGE_BEFORE_PN = "${PN}-version" |
| 14 | DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}" |
| 15 | |
| 16 | # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES |
| 17 | # handles the rest. |
| 18 | SYSTEMD_PACKAGES = "" |
| 19 | |
| 20 | inherit autotools pkgconfig |
| 21 | inherit obmc-phosphor-dbus-service |
| 22 | |
| 23 | DEPENDS += "autoconf-archive-native" |
| 24 | DEPENDS += "sdbusplus" |
| 25 | DEPENDS += "phosphor-dbus-interfaces" |
| 26 | |
| 27 | RDEPENDS_${PN}-version += "phosphor-dbus-interfaces sdbusplus" |
| 28 | |
| 29 | FILES_${PN}-version = "${sbindir}/phosphor-version-software-manager" |
Gunnar Mills | 17ee7b1 | 2017-02-22 11:41:12 -0600 | [diff] [blame] | 30 | DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.BMC.Version.service" |
Gunnar Mills | 35591d4 | 2017-01-27 13:13:24 -0600 | [diff] [blame] | 31 | |
| 32 | SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt" |
| 33 | SRCREV = "af4759e828690e51035c9d11c2a6845d9bb38406" |
| 34 | |
| 35 | S = "${WORKDIR}/git" |