blob: 49e0b058ab4096ce74eee3adb8a52e44b42c2d63 [file] [log] [blame]
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
2DESCRIPTION = "Phosphor OpenBMC filesytem mount reference implementation."
Brad Bishopab2908b2018-06-19 15:21:01 -04003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06005
Brad Bishopab2908b2018-06-19 15:21:01 -04006PR = "r1"
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06007
8S = "${WORKDIR}"
9SRC_URI += "file://obmc-init.sh"
10SRC_URI += "file://obmc-shutdown.sh"
11SRC_URI += "file://obmc-update.sh"
12SRC_URI += "file://whitelist"
13
14do_install() {
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060015 for f in init-download-url init-options
16 do
17 if test -e $f
18 then
19 install -m 0755 ${WORKDIR}/$f ${D}/$f
20 fi
21 done
Milton D. Miller IId89d5e02016-01-20 14:57:54 -060022 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
23 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
24 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
25 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
26 install -d ${D}/dev
27 mknod -m 622 ${D}/dev/console c 5 1
28}
29
30FILES_${PN} += " /init /shutdown /update /whitelist /dev "
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060031FILES_${PN} += " /init-options /init-download-url "