blob: 3fa88c9e66cb06b4d3b10e31b2e4d00b7a4a7acb [file] [log] [blame]
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
2DESCRIPTION = "Phosphor OpenBMC filesytem mount reference implementation."
3PR = "r1"
4
5inherit obmc-phosphor-license
6inherit obmc-phosphor-initfs
7
8S = "${WORKDIR}"
9SRC_URI += "file://obmc-init.sh"
10SRC_URI += "file://obmc-shutdown.sh"
11SRC_URI += "file://obmc-update.sh"
12SRC_URI += "file://whitelist"
13
14do_install() {
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060015 for f in init-download-url init-options
16 do
17 if test -e $f
18 then
19 install -m 0755 ${WORKDIR}/$f ${D}/$f
20 fi
21 done
Milton D. Miller IId89d5e02016-01-20 14:57:54 -060022 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
23 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
24 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
25 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
26 install -d ${D}/dev
27 mknod -m 622 ${D}/dev/console c 5 1
28}
29
30FILES_${PN} += " /init /shutdown /update /whitelist /dev "
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060031FILES_${PN} += " /init-options /init-download-url "