Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor LED Group Management meta data" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit obmc-phosphor-utils |
| 5 | inherit obmc-phosphor-license |
Brad Bishop | b3a24d6 | 2017-03-01 15:33:25 -0500 | [diff] [blame^] | 6 | inherit native |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 7 | |
| 8 | # Default is the example set of data. |
Brad Bishop | b3a24d6 | 2017-03-01 15:33:25 -0500 | [diff] [blame^] | 9 | PHOSPHOR_LED_MANAGER_CONFIG ??= "${BPN}-example-native" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 10 | |
| 11 | # Choose appropriate yaml file |
| 12 | def get_depends(d): |
| 13 | if d.getVar('USE_MRW', 'yes'): |
Brad Bishop | b3a24d6 | 2017-03-01 15:33:25 -0500 | [diff] [blame^] | 14 | return "${BPN}-mrw-native" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 15 | else: |
| 16 | return "${PHOSPHOR_LED_MANAGER_CONFIG}" |
| 17 | |
Brad Bishop | b943d91 | 2017-01-31 10:37:13 -0500 | [diff] [blame] | 18 | USE_MRW = "${@cf_enabled(d, 'obmc-mrw', 'yes')}" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 19 | DEPENDS += "${@get_depends(d)}" |