Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems" |
| 2 | DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems" |
| 3 | HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser" |
| 4 | PR = "r1" |
| 5 | |
| 6 | RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw" |
| 7 | |
| 8 | inherit obmc-phosphor-license |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 9 | inherit obmc-phosphor-systemd |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 10 | |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 11 | DEPENDS += " \ |
| 12 | systemd \ |
| 13 | host-ipmid \ |
| 14 | " |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 15 | |
| 16 | RDEPENDS_${PN} += "libsystemd" |
| 17 | |
Patrick Williams | 805d4db | 2016-08-30 15:17:16 -0500 | [diff] [blame] | 18 | TARGET_CXXFLAGS += " -fpic -std=gnu++14" |
Patrick Williams | 8592c8c | 2016-08-30 12:30:23 -0500 | [diff] [blame] | 19 | TARGET_CFLAGS += " -fpic" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 20 | SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 21 | |
| 22 | SRC_URI += "git://github.com/openbmc/ipmi-fru-parser" |
| 23 | |
Patrick Williams | c7d3e20 | 2016-08-30 11:50:02 -0500 | [diff] [blame] | 24 | SRCREV = "619db930483505aa4352b8ae30d6c6b5a9b569cf" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 25 | |
Brad Bishop | 431d598 | 2016-06-13 15:39:56 -0400 | [diff] [blame] | 26 | FILES_SOLIBSDEV += "${libdir}/host-ipmid/lib*${SOLIBSDEV}" |
| 27 | FILES_${PN} += "${libdir}/host-ipmid/lib*${SOLIBS}" |
| 28 | FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug/lib*${SOLIBS}" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
Chris Austen | 652fee8 | 2015-11-24 22:04:53 -0600 | [diff] [blame] | 32 | do_install() { |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 33 | oe_runmake install DESTDIR=${D} LIBDIR=${libdir} BINDIR=${sbindir} |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 34 | } |