blob: c8e49ed9930eca3813d68e0ecd87e004652823a2 [file] [log] [blame]
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -06001SUMMARY = "Network DBUS object"
2DESCRIPTION = "Network DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
4PR = "r1"
5
Matthew Barth2ece5742016-09-28 13:14:43 -05006inherit autotools pkgconfig
Ratan Gupta05787732017-04-28 10:12:54 +05307inherit pythonnative
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -06008inherit obmc-phosphor-license
Brad Bishopbce1a792016-09-06 20:37:22 -04009inherit obmc-phosphor-dbus-service
Patrick Williams5afacef2017-05-29 22:08:38 -050010inherit phosphor-networkd-rev
vishwab18b1332016-06-20 06:41:52 -050011
Brad Bishopbce1a792016-09-06 20:37:22 -040012DBUS_SERVICE_${PN} += "org.openbmc.NetworkManager.service"
Ratan Guptab6de45c2017-07-06 21:09:14 +053013DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.service"
14
Brad Bishopbce1a792016-09-06 20:37:22 -040015SYSTEMD_SERVICE_${PN} += "network-update-dns.service"
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060016
Matthew Barth95cd1b22016-10-24 12:51:20 -050017DEPENDS += "systemd"
Matthew Barth2ece5742016-09-28 13:14:43 -050018DEPENDS += "autoconf-archive-native"
Ratan Gupta05787732017-04-28 10:12:54 +053019DEPENDS += "sdbusplus sdbusplus-native"
20DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
21DEPENDS += "phosphor-logging"
22
Matthew Barth95cd1b22016-10-24 12:51:20 -050023RDEPENDS_${PN} += "libsystemd"
Patrick Ventureba084522017-06-15 09:19:58 -070024RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy python-subprocess"
Ratan Gupta05787732017-04-28 10:12:54 +053025RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
26RDEPENDS_${PN} += "phosphor-logging"
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060027
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060028S = "${WORKDIR}/git"
29
Brad Bishopbce1a792016-09-06 20:37:22 -040030do_install_append() {
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060031 install -d ${D}/${sbindir}
32 install ${S}/netman.py ${D}/${sbindir}
Ratan Gupta0f636982016-10-24 22:48:11 -050033 install ${S}/conf/network-manager.conf ${D}/${sysconfdir}
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060034}