blob: 2803a9b604a4d00c9a96130eebb2af7273a2936b [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060017DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylak78784092017-02-09 15:06:41 -060018DEPENDS += "phosphor-dbus-interfaces"
19RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylak172fe102016-10-19 14:58:25 -050020PROVIDES += "virtual/obmc-logging-mgmt"
21RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
22
23SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williamsb7716c72017-02-15 08:20:05 -060024SRCREV = "4ea7f312c508af64634a3e308b8641d39c581e37"
Adriana Kobylak172fe102016-10-19 14:58:25 -050025
26S = "${WORKDIR}/git"
27