blob: bf815ce03e5ed0d83860e6c5c28010ab2c4df057 [file] [log] [blame]
Patrick Williamsbb27bf22020-04-08 10:26:49 -05001SUMMARY = "sdbus++ dbus API / binding generator"
2DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
3
4inherit autotools pkgconfig
Patrick Williams7aba8152020-03-31 14:22:32 -05005inherit obmc-phosphor-python3-autotools
Patrick Williamsbb27bf22020-04-08 10:26:49 -05006
7include sdbusplus-rev.inc
8
9# Provide these aliases temporarily until everyone can move over to the
10# new package name.
11PROVIDES_class-native += "sdbusplus-native"
12PROVIDES_class-nativesdk += "sdbusplus-nativesdk"
13
14DEPENDS += " \
15 autoconf-archive-native \
16 ${PYTHON_PN}-inflection-native \
17 ${PYTHON_PN}-mako-native \
18 ${PYTHON_PN}-pyyaml-native \
19 "
20
21RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-inflection \
23 ${PYTHON_PN}-mako \
24 ${PYTHON_PN}-pyyaml \
25 "
26
27PACKAGECONFIG ??= "transaction"
28PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
29PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
30
31BBCLASSEXTEND += "native nativesdk"