blob: 82ed69c3318c2bab7a2c1451ab1094f790ec668f [file] [log] [blame]
Deepak Kodihalli394e8672019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5
6inherit meson pkgconfig
Deepak Kodihalli127d8972020-06-22 05:25:35 -05007inherit systemd
Deepak Kodihalli394e8672019-10-14 01:23:27 -05008
9require pldm.inc
10
11DEPENDS += "systemd"
Matt Spinler6fd86c42020-01-20 14:09:47 -060012DEPENDS += "sdeventplus"
Deepak Kodihalli394e8672019-10-14 01:23:27 -050013DEPENDS += "phosphor-dbus-interfaces"
14DEPENDS += "nlohmann-json"
Deepak Kodihalli394e8672019-10-14 01:23:27 -050015DEPENDS += "cli11"
16
17S = "${WORKDIR}/git"
18
Deepak Kodihalli127d8972020-06-22 05:25:35 -050019SYSTEMD_SERVICE_${PN} += "pldmd.service"
Chicago Duan42365972020-08-27 15:07:55 +080020SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service"
Deepak Kodihalli127d8972020-06-22 05:25:35 -050021
Deepak Kodihalli394e8672019-10-14 01:23:27 -050022EXTRA_OEMESON = " \
23 -Dtests=disabled \
24 -Doem-ibm=disabled \
25 "