Andrew Geissler | 9f8770e | 2017-01-10 15:12:03 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor Host State Management" |
| 2 | DESCRIPTION = "Phosphor Host State Manager provides a host state \ |
| 3 | object which manages the hosts in the system. It is suitable for use on \ |
| 4 | a wide variety of OpenBMC platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit obmc-phosphor-dbus-service |
| 12 | |
| 13 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.State.Host.service" |
| 14 | |
| 15 | RDEPENDS_${PN} += "libsystemd" |
| 16 | DEPENDS += "autoconf-archive-native" |
| 17 | DEPENDS += "sdbusplus" |
| 18 | DEPENDS += "phosphor-logging" |
| 19 | |
| 20 | PROVIDES += "virtual/obmc-host-state-mgmt" |
| 21 | RPROVIDES_${PN} += "virtual-obmc-host-state-mgmt" |
| 22 | |
| 23 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
| 24 | SRCREV = "794baed325213d39d75e5f8c3374177891ef70ec" |
| 25 | |
| 26 | S = "${WORKDIR}/git" |