Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor Power services and utilities" |
| 2 | DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \ |
| 3 | voltage regulators, and analyzes power devices for faults" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | inherit meson |
| 8 | inherit pkgconfig |
| 9 | inherit systemd |
Lei YU | 404e163 | 2020-03-06 10:26:57 +0800 | [diff] [blame] | 10 | inherit python3native |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 11 | |
Patrick Williams | c7d848e | 2020-04-03 15:48:30 -0500 | [diff] [blame] | 12 | require ${BPN}.inc |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 16 | POWER_SERVICE_PACKAGES = " \ |
| 17 | ${PN}-cold-redundancy \ |
| 18 | ${PN}-monitor \ |
| 19 | ${PN}-psu-monitor \ |
| 20 | ${PN}-regulators \ |
| 21 | ${PN}-sequencer \ |
| 22 | " |
| 23 | POWER_UTIL_PACKAGES = "${PN}-utils" |
| 24 | |
| 25 | PACKAGE_BEFORE_PN = "${POWER_SERVICE_PACKAGES} ${POWER_UTIL_PACKAGES}" |
| 26 | ALLOW_EMPTY_${PN} = "1" |
| 27 | |
| 28 | SYSTEMD_PACKAGES = "${POWER_SERVICE_PACKAGES}" |
| 29 | |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 30 | # TODO: in future when openpower-dbus-interfaces is removed from |
| 31 | # phosphor-power, remove the dependency here. |
| 32 | DEPENDS += " \ |
| 33 | phosphor-logging \ |
| 34 | openpower-dbus-interfaces \ |
Patrick Williams | 2bebd12 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 35 | ${PYTHON_PN}-sdbus++-native \ |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 36 | sdeventplus \ |
| 37 | nlohmann-json \ |
Jim Wright | 7a0e57f | 2019-11-06 15:43:43 -0600 | [diff] [blame] | 38 | cli11 \ |
Matthew Barth | 16867e4 | 2019-12-20 15:37:07 -0600 | [diff] [blame] | 39 | i2c-tools \ |
Lei YU | b16b306 | 2020-03-05 13:39:10 +0800 | [diff] [blame] | 40 | ${PYTHON_PN}-native \ |
| 41 | ${PYTHON_PN}-pyyaml-native \ |
| 42 | ${PYTHON_PN}-setuptools-native \ |
| 43 | ${PYTHON_PN}-mako-native \ |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 44 | " |
| 45 | |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 46 | SEQ_MONITOR_SVC = "pseq-monitor.service" |
| 47 | SEQ_PGOOD_SVC = "pseq-monitor-pgood.service" |
| 48 | PSU_MONITOR_TMPL = "power-supply-monitor@.service" |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 49 | PSU_MONITOR_SVC = "phosphor-psu-monitor.service" |
Matthew Barth | fa58fcd | 2019-12-20 15:42:35 -0600 | [diff] [blame] | 50 | REGS_SVC = "phosphor-regulators.service" |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 51 | |
| 52 | SYSTEMD_SERVICE_${PN}-sequencer = "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}" |
| 53 | SYSTEMD_SERVICE_${PN}-monitor = "${PSU_MONITOR_TMPL}" |
| 54 | SYSTEMD_SERVICE_${PN}-psu-monitor = "${PSU_MONITOR_SVC}" |
| 55 | SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC}" |
| 56 | |
| 57 | |
| 58 | # TODO: cold-redundancy is not installed in the repo yet |
| 59 | # FILES_${PN}-cold-redundancy = "${bindir}/cold-redundancy" |
| 60 | |
| 61 | FILES_${PN}-monitor = "${bindir}/psu-monitor" |
Brandon Wyman | f363ebf | 2020-03-12 15:10:48 -0500 | [diff] [blame] | 62 | FILES_${PN}-psu-monitor = "${bindir}/phosphor-psu-monitor ${datadir}/phosphor-psu-monitor" |
Lei YU | ae688cf | 2020-03-13 11:02:18 +0800 | [diff] [blame] | 63 | FILES_${PN}-regulators = "${bindir}/phosphor-regulators ${datadir}/phosphor-regulators" |
Lei YU | 2172cd1 | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 64 | FILES_${PN}-sequencer = "${bindir}/pseq-monitor" |
| 65 | FILES_${PN}-utils = "${bindir}/psutils" |