Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/git" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit pythonnative |
Marri Devender Rao | e341401 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 10 | inherit phosphor-dbus-yaml |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 13 | DEPENDS += "sdbus++-native" |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 14 | |
Patrick Williams | f6f2edb | 2017-01-30 11:05:56 -0600 | [diff] [blame] | 15 | SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces" |
Andrew Geissler | 1911167 | 2018-05-10 06:25:03 -0500 | [diff] [blame] | 16 | SRCREV = "779da1a6155783b058176e6480b9536a7df877bf" |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS_remove_class-native = "sdbus++-native" |
| 19 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 20 | |
| 21 | PACKAGECONFIG ??= "libphosphor_dbus" |
Brad Bishop | 82f51bf | 2017-02-13 14:28:28 -0500 | [diff] [blame] | 22 | PACKAGECONFIG[libphosphor_dbus] = " \ |
| 23 | --enable-libphosphor_dbus, \ |
| 24 | --disable-libphosphor_dbus, \ |
| 25 | systemd sdbusplus, \ |
| 26 | libsystemd sdbusplus \ |
| 27 | " |
Brad Bishop | 5f7b171 | 2017-02-02 20:49:22 -0500 | [diff] [blame] | 28 | |
| 29 | PACKAGECONFIG_remove_class-native = "libphosphor_dbus" |
| 30 | PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus" |
| 31 | |
| 32 | BBCLASSEXTEND += "native nativesdk" |