Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC PCIE slot detection utility" |
| 2 | DESCRIPTION = "OpenBMC PCIE slot detection utility." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-gdbus |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
| 8 | SKELETON_DIR = "pciedetect" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 9 | |
| 10 | TMPL = "pcie-slot-detect@.service" |
Josh D. King | a283e07 | 2017-04-06 15:56:37 -0500 | [diff] [blame] | 11 | TGTFMT = "obmc-host-start@{0}.target" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 12 | INSTFMT = "pcie-slot-detect@{0}.service" |
| 13 | FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}" |
| 14 | |
| 15 | SYSTEMD_SERVICE_${PN} += "pcie-slot-detect@.service" |
| 16 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |