Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for Phosphor OpenBMC systemd services. |
2 | |||||
3 | inherit systemd | ||||
4 | |||||
5 | SYSTEMD_SERVICE_${PN} = "${PN}.service" | ||||
6 | SRC_URI += " \ | ||||
7 | file://${PN}.service \ | ||||
8 | " | ||||
9 | |||||
10 | do_install_append() { | ||||
11 | # install systemd unit files | ||||
12 | install -d ${D}${systemd_unitdir}/system | ||||
13 | install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system | ||||
14 | } |