Ratan Gupta | 74b00f3 | 2018-03-21 00:34:08 +0530 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | SRC_URI += "file://avahi.conf" |
| 4 | SRC_URI += "file://check-avahi-pre-cond.service" |
| 5 | SRC_URI += "file://create-user" |
| 6 | SRC_URI += "file://check-local-domain" |
| 7 | |
| 8 | RRECOMMENDS_${PN}-daemon += "bind-utils" |
| 9 | |
| 10 | AVAHI_SVC = "avahi-daemon.service" |
| 11 | |
| 12 | AVAHI_DROPIN_DIR = "${AVAHI_SVC}.d" |
| 13 | |
| 14 | FILES_${PN}-daemon_append += "${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}/avahi.conf" |
| 15 | |
| 16 | PACKAGE_BEFORE_PN += "${PN}-daemon-preconditions" |
| 17 | |
| 18 | FILES_${PN}-daemon-preconditions += "${systemd_system_unitdir}/check-avahi-pre-cond.service" |
| 19 | FILES_${PN}-daemon-preconditions += "${sbindir}/create-user" |
| 20 | FILES_${PN}-daemon-preconditions += "${sbindir}/check-local-domain" |
| 21 | |
| 22 | RRECOMMENDS_${PN}-daemon += "${PN}-daemon-preconditions" |
| 23 | |
| 24 | do_install_append() { |
| 25 | |
| 26 | mkdir -p ${D}/${systemd_system_unitdir}/${AVAHI_DROPIN_DIR} |
| 27 | install -m 0755 ${WORKDIR}/avahi.conf ${D}/${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}/avahi.conf |
| 28 | install -m 0755 ${WORKDIR}/check-avahi-pre-cond.service ${D}/${systemd_system_unitdir}/check-avahi-pre-cond.service |
| 29 | install -m 0755 ${WORKDIR}/check-local-domain ${D}/${sbindir}/check-local-domain |
| 30 | install -m 0755 ${WORKDIR}/create-user ${D}/${sbindir}/create-user |
| 31 | } |