blob: 595024a55da7c8f65284590652ad1d4b8e75cd6c [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060017DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylaka6fc67f2017-01-30 20:30:00 -060018RDEPENDS_${PN} += "sdbusplus"
Adriana Kobylak172fe102016-10-19 14:58:25 -050019PROVIDES += "virtual/obmc-logging-mgmt"
20RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
21
22SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams68988262017-02-06 08:50:03 -060023SRCREV = "f542ba8271617afa73117a6a194572719760d734"
Adriana Kobylak172fe102016-10-19 14:58:25 -050024
25S = "${WORKDIR}/git"
26