blob: e449746ccb6f1388ccce61e08b182c12974d3d2e [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060017DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylaka6fc67f2017-01-30 20:30:00 -060018RDEPENDS_${PN} += "sdbusplus"
Adriana Kobylak172fe102016-10-19 14:58:25 -050019PROVIDES += "virtual/obmc-logging-mgmt"
20RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
21
22SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams7d95e702017-01-27 11:50:06 -060023SRCREV = "ac784ccd09e68fc8d74ed3b308230d61f9c9e12a"
Adriana Kobylak172fe102016-10-19 14:58:25 -050024
25S = "${WORKDIR}/git"
26