Andrew Geissler | e84b046 | 2020-04-14 11:25:29 -0500 | [diff] [blame] | 1 | inherit update-alternatives |
| 2 | |
| 3 | ALTERNATIVE_${PN}-core += "python" |
| 4 | ALTERNATIVE_LINK_NAME[python] = "${bindir}/python" |
| 5 | ALTERNATIVE_TARGET[python] = "${bindir}/python3" |
Andrew Geissler | d23fed5 | 2020-04-14 11:26:24 -0500 | [diff] [blame^] | 6 | |
| 7 | # Even though python3 is built with --without-ensurepip, it still installs |
| 8 | # a large, compressed version of pip. Remove it to free up the space. |
| 9 | do_install_append_class-target() { |
| 10 | rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip |
| 11 | } |