blob: 0db91f1795edfab6a9ae6791a9114e001abd43ea [file] [log] [blame]
Brad Bishop86605732015-11-18 10:56:38 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
Brad Bishop86605732015-11-18 10:56:38 -05002
Andrew Geissler20e22db2018-08-29 06:06:42 -07003# Remove all python .py files from python recipe. Only the .pyc
4# files are required. Only do this if the openbmc-phosphor-tiny
5# distro feature is enabled
6do_install_append_openbmc-phosphor-tiny() {
Andrew Geissleraa746402018-09-25 09:32:31 -05007 # The _sysconfigdata.py is a system configuration file generated
8 # during build time. It's used in the yocto packaging process so
9 # it is required to remain in the image.
10 find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata.py -exec rm {} \;
Andrew Geissler20e22db2018-08-29 06:06:42 -070011}