Patrick Williams | bb27bf2 | 2020-04-08 10:26:49 -0500 | [diff] [blame] | 1 | SUMMARY = "sdbus++ dbus API / binding generator" |
| 2 | DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs" |
| 3 | |
| 4 | inherit autotools pkgconfig |
Patrick Williams | 7aba815 | 2020-03-31 14:22:32 -0500 | [diff] [blame] | 5 | inherit obmc-phosphor-python3-autotools |
Patrick Williams | bb27bf2 | 2020-04-08 10:26:49 -0500 | [diff] [blame] | 6 | |
| 7 | include sdbusplus-rev.inc |
| 8 | |
| 9 | # Provide these aliases temporarily until everyone can move over to the |
| 10 | # new package name. |
| 11 | PROVIDES_class-native += "sdbusplus-native" |
| 12 | PROVIDES_class-nativesdk += "sdbusplus-nativesdk" |
| 13 | |
| 14 | DEPENDS += " \ |
| 15 | autoconf-archive-native \ |
| 16 | ${PYTHON_PN}-inflection-native \ |
| 17 | ${PYTHON_PN}-mako-native \ |
| 18 | ${PYTHON_PN}-pyyaml-native \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS_${PN} += " \ |
| 22 | ${PYTHON_PN}-inflection \ |
| 23 | ${PYTHON_PN}-mako \ |
| 24 | ${PYTHON_PN}-pyyaml \ |
| 25 | " |
| 26 | |
| 27 | PACKAGECONFIG ??= "transaction" |
| 28 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
| 29 | PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction" |
| 30 | |
| 31 | BBCLASSEXTEND += "native nativesdk" |