blob: f81e21dd1299e584baff6fd71bcc42b2725e321a [file] [log] [blame]
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
2DESCRIPTION = "Phosphor OpenBMC filesytem mount reference implementation."
3PR = "r1"
4
5inherit obmc-phosphor-license
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06006
7S = "${WORKDIR}"
8SRC_URI += "file://obmc-init.sh"
9SRC_URI += "file://obmc-shutdown.sh"
10SRC_URI += "file://obmc-update.sh"
11SRC_URI += "file://whitelist"
12
13do_install() {
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060014 for f in init-download-url init-options
15 do
16 if test -e $f
17 then
18 install -m 0755 ${WORKDIR}/$f ${D}/$f
19 fi
20 done
Milton D. Miller IId89d5e02016-01-20 14:57:54 -060021 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
22 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
23 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
24 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
25 install -d ${D}/dev
26 mknod -m 622 ${D}/dev/console c 5 1
27}
28
29FILES_${PN} += " /init /shutdown /update /whitelist /dev "
Milton D. Miller IIb1136c02016-03-07 14:42:50 -060030FILES_${PN} += " /init-options /init-download-url "