Brad Bishop | c642e5c | 2017-07-10 21:56:17 -0400 | [diff] [blame] | 1 | # Provides the config file for the phosphor-fan-presence application. |
| 2 | # The default config file is empty. To provide a real one, |
| 3 | # append this recipe in a layer, add: |
| 4 | # FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 5 | # and provide a config file. |
| 6 | |
| 7 | SUMMARY = "Config file for phosphor-fan-presence" |
| 8 | PR = "r1" |
Patrick Venture | ec372a8 | 2018-11-03 16:32:35 -0700 | [diff] [blame] | 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Brad Bishop | c642e5c | 2017-07-10 21:56:17 -0400 | [diff] [blame] | 11 | |
| 12 | inherit native |
| 13 | inherit phosphor-fan |
Brad Bishop | c642e5c | 2017-07-10 21:56:17 -0400 | [diff] [blame] | 14 | |
| 15 | PROVIDES += "virtual/phosphor-fan-presence-config" |
| 16 | |
| 17 | SRC_URI += "file://config.yaml" |
| 18 | |
| 19 | S = "${WORKDIR}" |
| 20 | |
| 21 | do_install() { |
| 22 | install -D config.yaml ${D}${presence_datadir}/config.yaml |
| 23 | } |