Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor Power services and utilities" |
| 2 | DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \ |
| 3 | voltage regulators, and analyzes power devices for faults" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | inherit meson |
| 8 | inherit pkgconfig |
| 9 | inherit systemd |
| 10 | inherit pythonnative |
| 11 | |
| 12 | require ${PN}.inc |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | # TODO: in future when openpower-dbus-interfaces is removed from |
| 17 | # phosphor-power, remove the dependency here. |
| 18 | DEPENDS += " \ |
| 19 | phosphor-logging \ |
| 20 | openpower-dbus-interfaces \ |
| 21 | sdbus++-native \ |
| 22 | sdeventplus \ |
| 23 | nlohmann-json \ |
Jim Wright | 7a0e57f | 2019-11-06 15:43:43 -0600 | [diff] [blame] | 24 | cli11 \ |
Matthew Barth | 16867e4 | 2019-12-20 15:37:07 -0600 | [diff] [blame] | 25 | i2c-tools \ |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 26 | " |
| 27 | |
Brandon Wyman | 4d2907b | 2020-01-23 16:30:02 -0600 | [diff] [blame] | 28 | PACKAGE_BEFORE_PN = "phosphor-psu-monitor" |
| 29 | FILES_phosphor-psu-monitor = "${bindir}/phosphor-psu-monitor \ |
| 30 | ${systemd_system_unitdir}/phosphor-psu-monitor.service" |
| 31 | |
Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 32 | SEQ_MONITOR_SVC = "pseq-monitor.service" |
| 33 | SEQ_PGOOD_SVC = "pseq-monitor-pgood.service" |
| 34 | PSU_MONITOR_TMPL = "power-supply-monitor@.service" |
| 35 | SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}" |
Matthew Barth | 280eeb9 | 2019-12-20 15:21:55 -0600 | [diff] [blame] | 36 | |
| 37 | # Package all phosphor-regulators config files |
| 38 | FILES_${PN} += "${datadir}/phosphor-regulators" |